Home AC acting very, very weird!

+9
Answered
So AC is on but there isn't any air coming from the registers. BUT there is air coming from the filter duct! It's literally blowing cool air out, not sucking air..... My system is only about a couple years old. Does anyone have any info on what's going on? Oh and the filter duct has this weird smell, almost like a chemical Freon smell.
  11 answers
  • Liliana Wells Liliana Wells on Jul 30, 2015
    If it's still under warranty, call the installer.
  • Jaxon Jaxon on Jul 30, 2015
    Check your condenser on the furnace end. Almost sounds like it's stopped up.
  • Norman Ransom Norman Ransom on Jul 30, 2015
    Jaxon is probably correct, it sounds like the condenser coil is stopped up. These coils are easily damaged when cleaning and are usually not easily accessed. They get stopped up usually due to not changing the filter often enough or using the wrong size filter. I would suggest having a licensed HVAC Tech. check it out and service the unit while they are there, regular service can save you on your electric bill and will make the unit last longer.
  • Mary Mary on Jul 30, 2015
    Check your blower motor.
  • Mary Mary on Jul 30, 2015
    Check your blower motor.
    • Josh Pope Josh Pope on Jul 31, 2015
      I had my service guy come out. It's the blower motor..... Luckily my unit is under warranty, now to get the part in. Unfortunately, it's going to take 2-3 days to get in and the weather's been 104-105.... :(
  • Dol344982 Dol344982 on Jul 31, 2015
    My window a/c compresser turns on but the fan does not. What could be wrong?
  • Dol344982 Dol344982 on Jul 31, 2015
    How do I check the blower motor? IT IS BUILT INTO MY WALL?Do I HAVE TO TAKE IT OUT OF THE WALL
  • Mary Mary on Jul 31, 2015
    Had the same problem. No warranty though. Very expensive 843.00 installed. Hot weather and no AC don't mix. Good luck to you and yours. Heres to cooler weather! =]}
  • Mary Tonningsen Mary Tonningsen on Aug 01, 2015
    @dolphinity, It could be the fan motor is out or needs a bearing or something. Have you tried taking the cover off and vacuuming it out? (if you can do something like that) Maybe it's just clogged? I don't know anything about window A/Cs, I'm just taking a shot in the dark. Good luck! With this heat we've had, I hope you can get it fixed soon!
  • Judy Judy on Aug 01, 2015
    Have you replaced the filter lately?
  • Josh Pope Josh Pope on Aug 02, 2015
    @dolphinity, my guy had to test the blower motor. From what he said, the motor used in newer full package units use this low amp motor but they're prone to failure.
Your comment...